Back to overview
Maintenance

Implementing the Apply System, and key features with terms of service.

May 18, 2026 at 12:30pm UTC  –  May 18, 2026 at 2:00pm UTC
Affected services
helperx.de

Resolved
May 18, 2026 at 2:00pm UTC

Maintenance ended

Created
May 18, 2026 at 12:30pm UTC

Helperx will be performing routine maintenance on May 18 starting at 14:30 (CEST). You may not be able to access helperx.de for a short period of time, but we’ll have things back up and running as soon as possible to minimize disruption to you.